發表文章

Linux 版 Steam 無法新增收藏庫資料夾

圖片
在 linux 的 Steam UI 要加新的資料夾當收藏庫儲存空間,卻跳出無法執行。   可先嘗試用 command 開 Steam: steam -console 待 Steam UI 打開後點介面裡的主控台頁籤在下方輸入: library_folder_add /foo/bar  若 UI 主控台顯示:Failed mounting that path!  這時就要手動修改 ~/.steam/steam/steamapps/libraryfolders.vdf 可在 linux console 執行:  sed -i '$i "1"{"path"" /foo/bar "}' ~/.steam/steam/steamapps/libraryfolders.vdf 再新啓動 steam UI 就大功告成🎉 補充一下在 steam -console 時,執行第一種方法不行時,查看 linux console 可以看到錯誤如下: sh: 列 1: /foo/bar /.steam_exec_test.sh: 拒絕不符權限的操作 Failed system(" /foo/bar /.steam_exec_test.sh") in execute test: 32256 另外, sed 中的 1 是收藏庫資料夾的序號,若現在要加的是第三個資料夾那可以改成 3,雖然測試出來即使序號重複 steam 還是會自動修正不改也沒差 。 

MS Windows 登入頁面自動選擇指定帳號

有時想要開機時指定帳號成為首選登入帳號,這要去修改註冊表。 打開 regedit 進入  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon 建立字串 (String): AutoAdminLogon 輸入值:1 輸入要設置的帳號到:DefaultUserName 以上大功告成,若要再達成自動登入則要參考自動登入那篇去修改。 另外,也可以加 domain 帳號,只要輸入 FQDN 型式即可。

MS windows 11 自動登入

 打開 regedit 進入  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\PasswordLess\Device 修改 DevicePasswordLessBuildVersion  DWORD (32bit) 值為 0  然後開 netplwiz 在這台電腦必需輸入使用者名稱及密碼 取消勾選  這樣每次開機都會自動登入到桌面了。

限制 ssh 權限

為了限制單一帳號在 ssh 可執行的權限,需要修改 authorized_keys: $vim  ~/.ssh/authorized_keys command=" /usr/bin/rsync --server --sender -rt . /foo/bar ", no-pty,no-port-forwarding,no-X11-forwardi ng,no-agent-forwarding ssh-rsa *** comment 主要替換 "" 中的指令及在 ssh-rsa 前加上那串紅字,就能把透過這個 key 的連線限制權限。  

反向 rsync 及免手動輸入密碼

直接暴力結論先上,我要用 rsync 備份遠端的資料到本機(反向同步),首先在發起連線端 (local) 生成 ssh key:  ssh-keygen -t rsa -b 4096 -f ~/.ssh/id_rsa_rsync_ foobar  再傳送 public key 至遠端主機 (remote): scp ~/.ssh/id_rsa_rsync_ foobar .pub foobar @ip:/ foo/bar /.ssh/authorized_keys  最後執行 rsync 同步檔案:   rsync -rt -e "ssh -i ~/.ssh/id_rsa_rsync_ foobar " account@ip:/ / foo/bar  以上大功告成🎉   key 是在第三方生成的,所以我還有把 private key 用 scp 傳送至發起連線端,這樣它才能免密碼連遠端。 再說明一下我給 rsync: -r (recursive):遞迴地複製目錄  -t (times):保留檔案修改時間 

VMware VM 打不開

肇因為實體機關機前未替 VM 關機或停機,雖然 VM 的狀態已是關機的了但開啓時會跳出錯誤而且無法開機。參考錯誤如下: Unable to change virtual machine power state: ?????? Cannot open the disk '/ path/to/foobar/VMname/VMname -cl1-000001.vmdk' or one of the snapshot disks it depends on. Module 'Disk' power on failed. Failed to start the virtual machine.  最簡單粗暴解法為刪除暫存檔, rm -r / path/to/foobar/VMname/ *.lck 當然未存的變更可能會丢失 。

Linux 連不上 Probox Soft Raid

我用的 Probox 本 身沒有 Raid 功能,但 也可在 Linux 裡用 Soft Raid,我用 Raid 5,不小心把它電源斷掉後一直無法正常掛載。 因為我的 mSATA 在 Linux 只會抓第一顆硬碟,所以都用 USB 在連接,那就先下 lsusb |grep 152d:  查看是否有找到 Probox 用的 USB 晶片。 確認有抓到晶片再看是發生什麼事,所以下 dmesg|grep 'md/raid' 。 [    9.788315] [   T1002] md/raid:md127: not clean -- starting background reconstruction [    9.788461] [   T1002] md/raid:md127: device sdf operational as raid disk 2 [    9.788464] [   T1002] md/raid:md127: device sdd operational as raid disk 0 [    9.788466] [   T1002] md/raid:md127: device sde operational as raid disk 1 [    9.794874] [   T1002] md/raid:md127: cannot start dirty degraded array. [    9.814271] [   T1002] md/raid:md127: failed to run raid set. 查看 Raid狀態: cat /proc/mdstat 會回報類似:  md127 : inactive 要重新建 Raid 連結: sudo mdadm --assemble --force /dev/md127 /dev/sde /dev/sdd /dev/sdf /dev/ sdg 卻會出現類似錯誤: mda...